0
(0)

El uso de la función SI, la función Y, la función O y la función NO, es algo recurrente que tarde o temprano a la mayoría de los usuarios de Excelse puede decargar gratuitamente aqui LibreOffice)  se les plantea al crear fórmulas. En esta hoja se describe cómo utilizar estas funciones.

Función SI

Función SI aislada

Si la puntuación en A1 es  igual o mayor a 19, entonces muestra 20; de lo contrario la pantalla A1 resulta en la fórmula

=SI(A1>=19;20;A1)

Si la entrada en A1 es “Descuento”, entonces reste el 10%; de lo contrario mantenga A1. Se traduce en la fórmula

=A1*SI(A1=»Descuento»;1-10%;1)

Funciones anidadas del SI

Si el puntaje en A1 es mayor que 12, entonces muestra «continuar»; si A1>18, entonces agrega «está bien», de lo contrario muestra «satisfactorio». Pero si A1<=12, entonces al mostrar «para ser mejorado» resulta en la fórmula

=SI(A1>12; «continuar», & SI(A1>18; «muy bien»; «satisfactorio»); «necesita mejorar»)

o por la fórmula

=SI(A1<12; «necesita mejorar»; SI(A1<18; «continuar, satisfactorio»; «continuar, muy bien»))

Si la nota en A1 es menor de 4, entonces muestra «nulo»; si A1 está entre 4 y 8, entonces muestra «promedio»; si A1 está entre 8 y 12, entonces muestra «promedio»; si A1 está entre 12 y 16, entonces muestra «bueno»; de lo contrario muestra «muy bueno».
se traduce en la fórmula

=SI(A1<4; «nulo»; SI(A1<8; «insuficiente»;SI(A1<12; «medio»; SI(A1<16; «bien»; «muy bien»))))

Función Y

ejemplo de una funciona Y AND en excel

Mostrar «¡Madame la Comtesse!» si se cumplen todas estas condiciones: A2 (sexo)=esposa, B2 (estatus)=esposa, C2 (marido)=cuentas y D2 (puntuación)=presente; de lo contrario mostrar «Hola» resulta en la fórmula

=SI(ET(A2=»mujer»;B2=»novia»; C2=»condesa»; D2=»presente»); «Señora  comtesse!»; «Buenos dias»)

Función O

Mostrar «Piloto» si A3 contiene alguno de los siguientes datos: avión, fórmula 1, motocicleta; mostrar «Conductor» si A3 contiene coche o trabajo; de lo contrario mostrar «?».
resulta en la fórmula

=SI(OR(A3=»avión»;A3=»fórmula 1″; A3=»motocicleta»); «Piloto»; IF(OR(A3=»coche»;A3=»trabaja»); «Conductor»;?»))

Función NO

La fórmula

=SI(ENT(A3)=A3; «entero»; «decimal»)

también puede ser escrito

=SI(NON(ENT(A3)=A3); «decimal»; «entero»)

así como

=SI(A4<>»francés»; «extranjero»; «europeo»)

es equivalente a

=SI(NON(A4=»Francés»); «extranjero»; «europeo»)

Combinaciones

Las funciones AND, OR, NOT se usan más a menudo junto con la función SI. Todo el interés (y el placer), para quien utiliza una hoja de cálculo, es definir una “tabla de verdad” y dibujar un diagrama de flujo que represente el algoritmo del problema a resolver, combinando las 4 funciones y cuidando de respetar los paréntesis y los punto y coma para que la fórmula funcione.

Tal fórmula debe ser probada sistemáticamente, probando todos los casos y los valores límite de las variables.

 

Artículos relacionados

Excel - Lista desplegable (simple)

Excel – Lista desplegable (simple)

Muchos sitios, enlaces y tutoriales ya han tratado el tema de la lista desplegable de celdas. Lo presentamos aquí en ...
Leer Más
Planificacion de vacaciones en excel a descargar de un modo gratuito

Hacer un planning rápidamente (vacaciones) en Excel

Objetivo Cada año, tenemos que llevar a cabo la planificación del trabajo. que incluye: formación, vacaciones, seguimiento, asignación … Aquí ...
Leer Más

¿De cuánta utilidad te ha parecido este contenido?

¡Haz clic en una estrella para puntuar!

Promedio de puntuación 0 / 5. Recuento de votos: 0

Hasta ahora, ¡no hay votos!. Sé el primero en puntuar este contenido.